HDU 1028 Ignatius and the Princess III(母函数)

news/2024/7/3 10:08:23 标签: HDU 1028, 母函数

题目:HDU-1028 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1028

题目:

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16806    Accepted Submission(s): 11830


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
4 10 20
 

Sample Output
  
5 42 627
 

这道题目很简单,直接构建母函数就行了,不懂得看上一篇博客讲的原理吧。http://blog.csdn.net/qq_33171970/article/details/50663426

代码~~

#include<iostream>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<cstdio>
using namespace std;
const int maxn= 125;
int a[maxn],b[maxn];
int n;
int main(){
	while(cin>>n){
		for(int i=0;i<=n;i++){            //依旧不限制个数合并起来写
			a[i]=1;
			b[i]=0;
		}
		for(int i=2;i<=n;i++){
			for(int j=0;j<=n;j++)
				for(int k=0;k+j<=n;k+=i)
					b[j+k]+=a[j];
			for(int j=0;j<=n;j++){
				a[j]=b[j];
				b[j]=0;
			}
		}
		cout<<a[n]<<endl;
	}
	return 0;
}

啦啦啦,好好学习天天向上啦~


http://www.niftyadmin.cn/n/1306275.html

相关文章

IE9和JPEG-XR:第一印象

One of the new features in IE9 is the support for the JPEG-XR format, which reportedly has a better compression. Is it something we should dive into ASAP? IE9的新功能之一是对JPEG-XR格式的支持&#xff0c;据说该格式具有更好的压缩率。 我们应该尽快涉足吗&…

JavaScript实现获取table中某一列的值

JavaScript实现获取table中某一列的值 1、实现源码 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns"http://www.w3.org/1999/xhtml"> …

HDU 1085 Holding Bin-Laden Captive!(母函数)

题目&#xff1a;HDU-1085 题目链接&#xff1a;http://acm.hdu.edu.cn/showproblem.php?pid1085 题目&#xff1a; Holding Bin-Laden Captive! Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19057 Accep…

WebService之CXF注解之一(封装类)

Teacher.java&#xff1a; /*** Title:Teacher.java* Package:com.you.model* Description:老师封装类* author:Youhaidong(游海东)* date:2014-5-5 下午11:03:13* version V1.0*/ package com.you.model;import java.io.Serializable;/*** 类功能说明* 类修改者 修改日期* 修改…

编程神书_向编程之神祈祷

编程神书Oh Almighty All-One (01), 全能的哦(01)&#xff0c; Grant me the courage to embrace and early adopt new cool technologies, the serenity to ignore distractions from new technology fads and the wisdom to tell the difference. 让我勇于接受和尽早采…

YSlow开发:自定义规则集

(This is part 3. See part one and part two.) (这是第3部分。请参见第1部分和第2部分。) There are two concepts to remember when working on your YSlow extensions and customizations: 在处理YSlow扩展和自定义项时&#xff0c;要记住两个概念&#xff1a; rules (or &q…

HDU 1171 Big Event in HDU

题目&#xff1a;HDU-1085 题目链接&#xff1a;http://acm.hdu.edu.cn/showproblem.php?pid1085 题目&#xff1a; Big Event in HDU Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 31958 Accepted Submi…

WebService之CXF注解之二(Service接口)

ITeacherService.java&#xff1a; /*** Title:ITeacherService.java* Package:com.you.service* Description:教师Service接口* author:Youhaidong(游海东)* date:2014-5-5 下午11:06:24* version V1.0*/ package com.you.service;import javax.jws.WebMethod; import javax.j…